<html>
<head>
<meta http-equiv="Content-Type" content="text/html; charset=Windows-1252">
</head>
<body style="word-wrap:break-word; color:rgb(0,0,0); font-size:14px; font-family:Calibri,sans-serif">
<div>
<pre style="white-space:pre-wrap">This is commentary on sections 3.1.3 and 3.2 related to dicts/lists/bindata in reference to Bob Steagall’s review of the getdns API - <a href="http://www.vpnc.org/pipermail/getdns-api/2014-January/000229.html">http://www.vpnc.org/pipermail/getdns-api/2014-January/000229.html</a>
</pre>
</div>
<div><br>
</div>
<div>Bob proposes a rename of functions related to dictionary and list element accessors. A small sample includes: </div>
<div>
<div><br>
</div>
<div>getdns_list_create => getdns_create_list</div>
<div>getdns_list_set_dict => getdns_set_list_element_as_dict</div>
<div>getdns_list_get_dict => getdns_get_list_element_as_dict</div>
<div><br>
</div>
<div><span style="font-family:monospace; font-size:medium; white-space:pre">getdns_dict_set_list => get</span>dns_set_dict_element_as_list</div>
<div><br>
</div>
<div>I like the proposed name changes as it makes it clearer what is happening to the datastructure being modified. It also feels more readable to me.</div>
<div><br>
</div>
<div>Section 3.2 proposes adding a couple of helpers for working with bindatas. Specifically something like:</div>
<div><br>
</div>
<div>
<div>getdns_set_list_element_as_bindata_2 </div>
<div>( </div>
<div> getdns_list_t this_list, </div>
<div> size_t index, </div>
<div> uint8_t* bindata_content, </div>
<div> size_t bindata_size </div>
<div>); </div>
</div>
<div><br>
</div>
<div>I like the thought and have no problem including them in the core (though I dislike the _2 suffix). This relates to the discussion in <a href="http://www.vpnc.org/pipermail/getdns-api/2014-January/000219.html">http://www.vpnc.org/pipermail/getdns-api/2014-January/000219.html</a> -
it is possible that we can create a utility library that operates on top of the getdns spec and exposes some of these entry points for the user without affecting the core, and then gradually bring them in as needed.</div>
<div><br>
</div>
<div>That said, these functions are trivial for us to implement in the core right now, so maybe it is worth pulling them in.</div>
<div><br>
</div>
<div>Thoughts?</div>
<div><br>
</div>
</div>
<h5><font color="gray">“This message (including any attachments) is intended only for the use of the individual or entity to which it is addressed, and may contain information that is non-public, proprietary, privileged, confidential and exempt from disclosure
under applicable law or may be constituted as attorney work product. If you are not the intended recipient, you are hereby notified that any use, dissemination, distribution, or copying of this communication is strictly prohibited. If you have received this
message in error, notify sender immediately and delete this message immediately.”
</h5>
</font>
</body>
</html>